fragen stichworte

Fragen markiert [rubygems]

RubyGems ist ein Paketmanager für die Programmiersprache Ruby, der ein Standardformat für die Verteilung von Ruby-Programmen und -Bibliotheken (in einem eigenständigen Format, "Gem" genannt), ein Tool zur einfachen Verwaltung der Installation von Gems und einen Server für verteilen sie.

Lern mehr...
1
stimmen
3
antworten
2k
ansichten
Verwenden Sie gcc anstelle von SUNWspro cc in ruby ​​mkmf für yajl unter Solaris 10
Wie bekomme ich, dass mkmf gcc anstelle von/opt/SUNWspro/bin/cc unter Solaris 10 verwendet? Ich versuche, Chefkoch mit Edelsteininstallationskoch zu installieren. Es…
7
stimmen
2
antworten
5k
ansichten
Wie sucht Sudo den Pfad nach ausführbaren Dateien?
Ich benutze Rubygems (1.3.7) mit Gems, für die Root-Rechte auf Ubuntu 10.10 erforderlich sind. Wenn ich mein Setup mit einer…
2
stimmen
4
antworten
3k
ansichten
Rubin auf Schienen gitorious Setup auf Ubuntu
Ich habe schon seit einiger Zeit versucht, gitorious zu installieren, was Ruby und Rails usw. erforderlich machte. Ich habe nun…
0
stimmen
1
antworten
2k
ansichten
Nach dem ersten Setup kann sich die Foreman-Webkonsole nicht mit dem Administratorkonto anmelden
Bearbeiteter Post, um zu zeigen, wie ich Vorarbeiter installiert habe Ich bin neu bei Ruby und versuche Foreman auf CentOS…
0
stimmen
1
antworten
1k
ansichten
So starten Sie den Passagier-Nginx, Fehler: Signal empfangen. Stilles Herunterfahren ... (Sende Signal 2 weitere Zeit (en) zum Erzwingen des Herunterfahrens)
Die Anwendung ist im Produktionsmodus fehlerhaft und beim Neustart von Passenger und Nginx wird ein Fehler angezeigt.[ agents/LoggingAgent/Main.cpp:338 ]: Signal…
0
stimmen
1
antworten
1k
ansichten
ruby beschwert sich über ein nicht installiertes Paket, das tatsächlich installiert ist
Diese Frage mag sehr unprofessionell sein, aber ich bin nicht mit Ruby beschäftigt und habe keine Ahnung, wo ich anfangen…
1
stimmen
1
antworten
4k
ansichten
Installation von Rubygems nach der manuellen Installation von Ruby 1.8
Ich habe Ruby 1.8.7 unter Ubuntu 14.04 erfolgreich installiert, indem ich das Paket heruntergeladen, lokal erstellt und installiert habe. Der…
0
stimmen
2
antworten
958
ansichten
Unicorn-Installationsfehler unter Debian 5
Ich habe Ruby1.9 unter Debian 5 ausgeführt und konnte "Unicorn" nicht mit Rubygems installieren. Ich habe diesen Fehler erhalten und…
3
stimmen
1
antworten
2k
ansichten
Bundler: Befehl nicht gefunden: Einhornracks
Beim Neustart von gitlab bekomme ich folgendes:Starting both the GitLab Unicorn and Sidekiqbundler: command not found: unicorn_rails Install missing gem…
1
stimmen
2
antworten
4k
ansichten
Puppet kann Rubygem nicht installieren, das normalerweise ordnungsgemäß installiert wird
Ich verwende Folgendes, um eine Rubygem mit Puppet zu installieren und zu installieren.package { 'reaper': ensure => 'installed', provider =>…
1
stimmen
2
antworten
2k
ansichten
Wie entferne ich alle Ruby-Edelsteine ​​vollständig?
Ich versuche, meine Ruby and Rails-Installation vollständig zu entfernen. Nachdem ich Ruby mit apt-get remove ruby1.9.1 deinstalliert habe, sehe ich,…
0
stimmen
1
antworten
1k
ansichten
Fehler beim Installieren der neuen Schienenversion. Die native Erweiterung von Gem konnte nicht erstellt werden
Ich versuche, meine erste Ruby on Rails-App mithilfe der folgenden Anleitung (http://ruby.railstutorial.org/chapters/a-demo-app#code-demo_gemfile_sqlite_version_redux) zu erstellen und auszuführen in ein paar Hindernisse.…
2
stimmen
1
antworten
7k
ansichten
Abhängigkeitsprobleme bei der Installation von curl-devel
Ich versuche, passenger-install-apache2-module auszuführen, damit ich Redmine auf CentOS 5.8 installieren kann, aber passenger-install-apache2-module sagt mir, dass ich Curl development…
0
stimmen
3
antworten
2k
ansichten
Datei kann nicht geladen werden - OpenSSL (LoadError)
Ich habe ein Problem mit einer nicht kooperativen LTS-Instanz von EC2 Ubuntu 10.04 4. Ich versuche, ein paar Voraussetzungen für…
2
stimmen
1
antworten
2k
ansichten
ActiveAdmin Benutzerverwaltung
Ich bin neu bei Ruby on Rails. Ich verwende ActiveAdmin für Verwaltungszwecke. Ich habe viel über "wie man Admin-Benutzer verwaltet"…
7
stimmen
5
antworten
2k
ansichten
RVM nimmt / etc / gemrc nicht auf
in einer systemweiten RVM .... heres mein/etc/gemrc--- gem:--no-ri --no-rdoc ist das System gem envGEM PATHS: -/usr/lib/ruby/gems/1.9.1 -/home/${USER}/.gem/ruby/1.9.1 GEM CONFIGURATION: -…
6
stimmen
8
antworten
992
ansichten
gem vs apt-get in einer Serverumgebung
Wo sollte ich die Grenze zwischen apt-get und gem ziehen, wenn Sie einen Server einrichten, um Ruby auf Rails mit…
1
stimmen
3
antworten
2k
ansichten
Wie kann ich Software von einem RHEL 5-System deinstallieren?
Ich habe Rubygems 1.3.4 auf einem RHEL 5-System installiert. Sie installieren die Quelle, indem Sie die Quelle herunterladen und setup.rb…
1
stimmen
5
antworten
8k
ansichten
Mysql Ruby-Edelstein auf 64-Bit-CentOS installieren
Ich habe ein Problem bei der Installation von mysql ruby ​​gem auf 64-Bit-CentOS-Maschinen.[jacekb@vitaidealn ~]$ uname -a Linux vitaidealn.local 2.6.18-92.el5 #1…
0
stimmen
3
antworten
2k
ansichten
Passagier "Missing the Rails 2.3.4 gem" nach Apache-Neustart
Ich habe eine Schienen-App, die auf Passagier/Apache 2.2.3/RHEL ausgeführt wird. Alles funktionierte gut, bis ich Apache neu starten musste. Nachdem…
5
stimmen
3
antworten
7k
ansichten
Wie deinstallieren Sie die Rubygem-Anwendung?
Wir haben die Anwendung rubygem (Version 1.3.6) auf einem Debian-System installiert, indem wir das Archiv für rubygems tar.gz heruntergeladen und…
13
stimmen
2
antworten
30k
ansichten
Überprüfen Sie, welche Version von Rubygems auf Ubuntu installiert ist.
Wie überprüfe ich, welche Version von Rubygems ich auf meiner Ubuntu-Box installiert habe?
6
stimmen
2
antworten
20k
ansichten
So richten Sie Ruby und RubyGems unter CentOS ein
Ich habe einen CentOS 5.5 (64-Bit-Server) Ich möchte Ruby 1.8.7 (aktuelles Patch-Level) und RubyGems installieren Wie gehen Sie am besten…
2
stimmen
2
antworten
1k
ansichten
Entfernt ~ / .rvm / alles was ich brauchte, um eine Neuinstallation durchzuführen
Ich habe Ruby und Edelsteine ​​unter ~/.rvm/installiert. Jetzt möchte ich alle Dateien erneut installieren. Gibt es Änderungen/Links außerhalb dieses Ordners?…
2
stimmen
1
antworten
1k
ansichten
segfault in timeout.rb mit gem mit Ruby Enterprise Edition (ree-1.8.7)
Ich versuche ein Juwel auf meinem neuen Ubuntu 12.10 (GNU/Linux 3.6.5-x86_64-linode28 x86_64) Server zu installieren, und ich bekomme einen segfault…
0
stimmen
1
antworten
1k
ansichten
Der kompilierte Rubin findet keine Flüche
Ich versuche die sup MUA zu installieren, aber ich habe Probleme. Wenn ich versuche, es auszuführen, kann curses nicht gefunden…
0
stimmen
2
antworten
1k
ansichten
Die Installation von gem MySQL ist fehlgeschlagen
Ich installiere mysql gem auf Amazon AMI 2010.11.1 und habe das nächste Problem:# gem install mysql Building native extensions. This…
0
stimmen
1
antworten
2k
ansichten
-bash: / usr / bin / ruby: Keine solche Datei oder Verzeichnis
Ich habe in diesem Tutorial Ruby 1.9.2 auf meinem Centos-Server installiert. http://blog.jeffcosta.com/2010/09/10/7-steps-to-rails-on-centos/ Es besagt, dass es an den folgenden Speicherorten…
0
stimmen
1
antworten
1k
ansichten
Wie aktualisiere ich die curl-Version auf Ubuntu 8.04?
Auf meinem System 8.04 ist curl 7.18.0 installiert: curl --version zeigt:curl 7.18.0 (i486-pc-linux-gnu) libcurl/7.18.0 OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.1 Protocols: tftp ftp…
1
stimmen
2
antworten
2k
ansichten
Wo sollte ich auf einem Windows-System die gemrc-Datei ablegen, damit Puppet sie finden kann?
Ausführen von Puppet Enterprise 3.7. Der Agent-Computer ist ein Windows 2012 Server R2 -Feld. Frage: Wo kann ich die gemrc-Datei…
0
stimmen
3
antworten
1k
ansichten
Wie kann man Rubygems auf Ruby 1.9.1 verweisen?
[Debian Squeeze] Es war überraschend schwierig, eine Antwort darauf zu finden. Ich hatte Ruby v1.9.1 installiert (/usr/bin/ruby1.9.1), aber nachdem ich…
1
stimmen
3
antworten
4k
ansichten
So überprüfen Sie, ob PostgreSQL 9 auf einem CentOS-Server ordnungsgemäß installiert wurde?
Ich versuche, den PG (postgres) auf einem CentoOS-Server zu installieren, aber Postgres ist zu alt, obwohl ich ihn auf 9.1.3…
0
stimmen
1
antworten
1k
ansichten
Die RubyGem-Installation kann keine Header-Dateien finden
Ich verwende Ruby 1.9.3 unter CentOS 5.3. Ich habe es installiert, indem ich Ruby 1.9.3 zusammen mit libyaml aus dem…
4
stimmen
2
antworten
1k
ansichten
Wie kann Chef-Server Ruby 1.9 unter Ubuntu verwenden?
Ich habe Chef Server auf Ubuntu 12.04 mit den offiziellen Anweisungen installiert, die den "Omnibus-Installer" verwenden, der Ruby 1.8.7 eingebettet…
1
stimmen
1
antworten
2k
ansichten
Probleme beim Installieren von Gems mit nativen Erweiterungen auf Amazon Linux
Wenn ich versuche, Edelsteine ​​wie ohai und fpm auf meiner Amazon Linux EC2-Instanz zu installieren, bekomme ich die Fehlermeldung:[ec2-user@ip-172-31-43-16 ~]$…