fragen stichworte

Fragen markiert [rpm]

RPM Package Manager ist ein Paketverwaltungssystem, das hauptsächlich für GNU/Linux-Betriebssysteme verwendet wird. Es verwendete das RPM-Dateiformat.

Lern mehr...
1
stimmen
2
antworten
4k
ansichten
Wie aktivieren Sie GD in PHP bei der Installation über RPM?
Wir arbeiten an einem Client-Server, auf dem PHP ohne GD ausgeführt wird. Wir möchten die GD-Unterstützung in PHP auf diesem…
2
stimmen
3
antworten
1k
ansichten
Installation mit easy_install und bdist_rpm möglich?
Ich richte einen neuen Server ein, der auf RHEL5 basiert, und wollte einige Python-Module installieren, die nicht dazu gehören. Ich…
13
stimmen
6
antworten
9k
ansichten
Python 3.0 RPMs für CentOS 5 (RHEL 5)
Wo ist das beste Repository, das Sie verwenden, um RPMs für Python 3.0 zu erhalten, die gut gewartet werden?
3
stimmen
6
antworten
5k
ansichten
Aktuelles Repository für CentOS git RPMS
Ich verwalte derzeit manuell Git-Pakete für meine CentOS-Maschinen, da in den Repos anscheinend keine aktuellen Pakete verfügbar sind. Ich baue…
5
stimmen
3
antworten
5k
ansichten
Transaktionen und Rollback mit Debian
Ich weiß nicht, ob es allgemein bekannt ist, aber RPM unterstützt das Rollbacking zu einer vorherigen Installation nach einem Upgrade…
1
stimmen
1
antworten
3k
ansichten
Ersetzen Sie mit YUM eine zu einem installierten RPM gehörende Datei durch ein anderes RPM
So ersetzen Sie eine Datei, die zu einem installierten RPM gehört, durch ein anderes RPM (ein Hotfix-RPM), das dieselbe Datei…
13
stimmen
1
antworten
6k
ansichten
Wie finde ich heraus, mit welchen Optionen ein RPM kompiliert wurde?
Ich muss die Kompilierungsoptionen für exim finden, wie von Fedora 11 verpackt. Gibt es im Allgemeinen einen einfachen Weg, um…
rpm
1
stimmen
2
antworten
903
ansichten
Wie kann ich unter CentOS 4.4 "rpmlet-fehlgeschlagene" Fehler von rpm -e diagnostizieren?
Während der Deinstallation eines RPM unter CentOS 4.4 wird angezeigt error: %preun(mypackage-1.0) scriptlet failed, exit status 1 Wie kann ich…
19
stimmen
3
antworten
18k
ansichten
Fedora-RPMs in CentOS installieren
Wie sicher ist es, Fedora RPMs in CentOS 5 zu installieren? Kommt es auf die Version des Fedora-RPM an oder…
2
stimmen
5
antworten
1k
ansichten
Konfiguration über RPMs verwalten?
Ich muss einige Konfigurationsanpassungen an mehreren Servern in unserem Netzwerk für kleine Abteilungen vornehmen. Wir verwenden derzeit RHEL5, und da…
2
stimmen
4
antworten
1k
ansichten
RPM-Datenbank ist beschädigt
Vor einiger Zeit ist es mir gelungen, den Ordner/var/lib/rpm zu löschen, der im Wesentlichen Informationen zu allen RPMS im System…
0
stimmen
1
antworten
8k
ansichten
Tomcat 6 auf Centos 5 - nur RPMs
Ich mache gerade die Übung, Tomcat 6 unter Verwendung von RPM-Paketen unter CentOS 5 einzurichten. Im Moment stecke ich bei…
6
stimmen
1
antworten
2k
ansichten
Wie kann ich verhindern, dass yum ein bestimmtes RPM aktualisiert?
Aus bestimmten Gründen muss auf meiner Box (Fedora 11) eine etwas ältere Version eines bestimmten RPM installiert sein. Das Problem…
0
stimmen
1
antworten
1k
ansichten
Installieren eines gcc und make auf einem sauberen SUSE 10-Computer
Ich habe eine saubere SUSE 10-Maschine erhalten, auf der ich eine Entwicklungsumgebung installieren muss. Derzeit muss ich GCC 3.2.3 und…
2
stimmen
2
antworten
10k
ansichten
Wie entferne ich ein Paket in openSUSE, ohne etwas zu installieren?
Ich habe einen openSUSE-Server, auf dem viele nicht benötigte Pakete installiert sind, die ich entfernen möchte. Ich finde jedoch, dass…
11
stimmen
8
antworten
10k
ansichten
rpm ohne Wurzel
Ist es möglich, rpm ohne Root-Zugriff zu verwenden?
rpm
9
stimmen
5
antworten
18k
ansichten
rpm, das eine Datei bereitstellt
Mit welchem ​​Befehl können Sie auflisten, welche RPM-Dateien eine bestimmte Datei bereitstellen können: das RPM, das bereits installierte Dateien bereitstellt,…
6
stimmen
3
antworten
10k
ansichten
OpenSSL 0.9.8k oder höher unter CentOS 5?
Ich muss OpenSSL auf meinem CentOS-Server auf 0.9.8k oder höher aktualisieren. Die neueste Version in den offiziellen CentOS-Repositorys ist jedoch…
1
stimmen
4
antworten
3k
ansichten
Aktualisieren von Samba aus RPMs
Meine Red Hat Enterprise Edition 4 wird mit Samba Version 3.0.10 geliefert. Diese unterstützt nicht das Attribut "Besitzer vererben", das…
3
stimmen
2
antworten
7k
ansichten
Unterschied zwischen RPM (yum) und apt-get
Funktionsunterschied zwischen den beiden? Pakete anders oder was? Ich tauche meinen Zeh in den Server-Pool und spiele gerade mit einer…
6
stimmen
2
antworten
1k
ansichten
Erstellen einer rpm-Datei mit angefügtem eindeutigen Qualifikationsmerkmal
Ich baue RPMs in einer kontinuierlichen Integrationsumgebung, und ich muss zwischen aufeinanderfolgenden Builds unterscheiden, aber offensichtlich wird die Spezifikationsdatei nicht…
rpm
0
stimmen
2
antworten
1k
ansichten
Fehler beim Kompilieren / Installieren von PHP mit FPM für RPM unter Centos 5.4 x64
Ich versuche ein RPM mit PHP 5.3.1 und PHP-FPM 0.6 für CentOS 5.4 zu erstellen. Bisher geht es ganz gut,…
3
stimmen
1
antworten
3k
ansichten
RPM-Build-Problem
Ich baue meine RPMS so: rpmbuild -bb SPECS/python.spec Mit der folgenden Spezifikationsdatei:%define _topdir/home/rpmbuild/python %define name Python %define release 1 %define…
rpm
3
stimmen
1
antworten
1k
ansichten
RPM-Installationsprogramm-Exitcode 24
Gibt es eine Liste von RPM-Exit-Codes, wenn ich den Link habe? Weiß auch jeder, was Exit-Code 24 aus einer RPM-Installation…
rpm
29
stimmen
5
antworten
77k
ansichten
Wie liste ich RPM-Abhängigkeiten auf?
Auf unserem Produktionsserver wird CentOS Version 5.2 (Final) ausgeführt. Wie kann ich alle Abhängigkeiten eines bereits installierten RPM-Pakets anzeigen/erhalten/auflisten? Zum…
1
stimmen
2
antworten
1k
ansichten
Reparieren von Yum auf einem RHEL5
Ich verwende RHEL5 und yum fehlen viele Pakete wie Apache, PHP und alle PHP-Bibliotheken. Ich habe das RPM-Archiv hinzugefügt, aber…
0
stimmen
2
antworten
1k
ansichten
wxGTK-devel auf CentOS 5.4 installieren
Ich versuche, wxGTK-devel unter CentOS zu installieren. Da es sich nicht im Basis-Repo befindet, habe ich RPMForge hinzugefügt. Aber jetzt…
4
stimmen
2
antworten
3k
ansichten
CentOS-Repositories: EPEL oder rpmforge, welches ist besser und warum?
Jeder, der CentOS verwendet, weiß also, dass die Standard-Repositorys ihre Grenzen haben. Ich verwende rpmforge seit Jahren als sekundäres Repo.…
0
stimmen
1
antworten
2k
ansichten
"yum upgrade git" centos
Ich möchte git aktualisieren, da die Version auf centos5 1.5.5.6 ist. yum upgrade git sagt: "Keine Pakete zur Aktualisierung markiert."…
2
stimmen
2
antworten
7k
ansichten
Wie installiere ich ein Python-RPM-Paket unter Windows?
Ich möchte gerne import rpm Wo finde ich in meinem Python-Skript in Windows die Installationspakete für das Python-RPM-Modul?
2
stimmen
2
antworten
1k
ansichten
Wie ändern Sie topdir als Benutzer in SSH?
Ich habe an verschiedenen Stellen NIE gelesen, um RPMs als Root-Benutzer zu erstellen. Daher habe ich einen neuen Benutzer definiert…
2
stimmen
2
antworten
2k
ansichten
Wie installiere ich Python 2.6 unter Fedora 8?
Ich möchte Fedora 8 nicht verwenden. Ich würde mich sehr über die neueste Version freuen, aber es gibt keine Wahl.…
4
stimmen
3
antworten
1k
ansichten
Wie man mit Puppet-Versionsunterschieden zwischen Linux-Distributionen umgeht
Wir sind ein kleiner Webdev-Shop, der Puppet auf verschiedenen Entwicklungs- und Produktionsservern einführt. Der Puppetmaster ist ein Ubuntu 10.04 Server…
3
stimmen
1
antworten
4k
ansichten
Welcher RPM behebt diese fehlgeschlagene RedHat-Abhängigkeit?
Problem Ich installiere ein RPM unter RedHat Enterprise Linux 5 und schlägt mit dem folgenden Fehler fehl:error: Failed dependencies: rpmlib(PayloadIsLzma)…
0
stimmen
2
antworten
1k
ansichten
wie man rpm-Makro überschreibt
Ich habe jetzt ungefähr 3 Stunden verbracht. Wie kann ich ein Makro während des RPM-Builds überschreiben? Ich möchte _sbindir (/usr/sbin)…