fragen stichworte

CentOS 5 - Yum-Aktualisierungsabhängigkeitsfehler

Ich versuche ein Update auf meinem CentOS VPS auszuführen. Was ich letztendlich versuche, ist ein Upgrade von php53 auf php55. Ich scheine jedoch auf einige Abhängigkeitsprobleme zu stoßen. Nachfolgend finden Sie Befehle und Ausgänge. Ich habe versucht, so viele Informationen wie möglich anzugeben. Über Feedback würden wir uns freuen. (Auch Plesk 11 läuft, aber ich denke nicht, dass das wichtig sein sollte).

yum liste installiert php *

Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * webtatic-el5: nl.repo.webtatic.com
Installed Packages
php5-ioncube-loader.x86_64               4.2.2-13031415                installed
php53.x86_64                             5.3.3-22.el5_10               installed
php53-cli.x86_64                         5.3.3-22.el5_10               installed
php53-common.x86_64                      5.3.3-22.el5_10               installed
php53-gd.x86_64                          5.3.3-22.el5_10               installed
php53-imap.x86_64                        5.3.3-22.el5_10               installed
php53-mbstring.x86_64                    5.3.3-22.el5_10               installed
php53-mysql.x86_64                       5.3.3-22.el5_10               installed
php53-pdo.x86_64                         5.3.3-22.el5_10               installed
php53-xml.x86_64                         5.3.3-22.el5_10               installed

rpm -q centos-release

centos-release-5-10.el5.centos

rpm -qa | grep 'php53 -'

php53-mysql-5.3.3-22.el5_10
php53-cli-5.3.3-22.el5_10
php53-gd-5.3.3-22.el5_10
php53-imap-5.3.3-22.el5_10
php53-pdo-5.3.3-22.el5_10
php53-xml-5.3.3-22.el5_10
php53-5.3.3-22.el5_10
php53-common-5.3.3-22.el5_10
php53-mbstring-5.3.3-22.el5_10

yum repolist

Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * epel: mirror.bytemark.co.uk
 * webtatic-el5: nl.repo.webtatic.com
repo id      repo name                                                    status
atomic       CentOS/Red Hat Enterprise Linux 5 - atomicrocketturtle.com 1,499
epel         Extra Packages for Enterprise Linux 5 - x86_64               7,694
webtatic-el5 Webtatic Repository EL5 - x86_64                               191
repolist: 9,384

yum-Update

Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * epel: mirror.bytemark.co.uk
 * webtatic-el5: nl.repo.webtatic.com
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package bash-completion.noarch 1:1.3-7.el5 set to be updated
---> Package perl-Text-Iconv.x86_64 0:1.4-5.el5 set to be updated
---> Package php.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-cli.x86_64 0:5.4.28-34.el5.art set to be updated
--> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
---> Package php-common.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-gd.x86_64 0:5.4.28-34.el5.art set to be updated
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
---> Package php-imap.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-ioncube-loader.x86_64 1:4.4.1-3.el5.art set to be updated
--> Processing Dependency: php-devel for package: php-ioncube-loader
---> Package php-mbstring.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-pdo.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-xml.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package python26.x86_64 0:2.6.8-2.el5 set to be updated
---> Package python26-libs.x86_64 0:2.6.8-2.el5 set to be updated
--> Running transaction check
---> Package libedit.x86_64 0:3.0-2.20090923cvs.el5.art set to be updated
---> Package php-devel.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package t1lib.x86_64 0:5.1.2-2.el5.art set to be updated
--> Processing Dependency: libXaw.so.7()(64bit) for package: t1lib
--> Finished Dependency Resolution
t1lib-5.1.2-2.el5.art.x86_64 from atomic has depsolving problems
  --> Missing Dependency: libXaw.so.7()(64bit) is needed by package t1lib-5.1.2-2.el5.art.x86_64 (atomic)
Error: Missing Dependency: libXaw.so.7()(64bit) is needed by package t1lib-5.1.2-2.el5.art.x86_64 (atomic)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

yum update php

Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * epel: mirror.bytemark.co.uk
 * webtatic-el5: nl.repo.webtatic.com
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package php.x86_64 0:5.4.28-34.el5.art set to be updated
--> Processing Dependency: php-common = 5.4.28-34.el5.art for package: php
--> Processing Dependency: php-cli = 5.4.28-34.el5.art for package: php
--> Running transaction check
---> Package php-cli.x86_64 0:5.4.28-34.el5.art set to be updated
--> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
---> Package php-common.x86_64 0:5.4.28-34.el5.art set to be updated
--> Processing Dependency: php53-common = 5.3.3-22.el5_10 for package: php53-mbstring
--> Processing Dependency: php53-common = 5.3.3-22.el5_10 for package: php53-gd
--> Processing Dependency: php53-common = 5.3.3-22.el5_10 for package: php53-pdo
--> Processing Dependency: php53-common = 5.3.3-22.el5_10 for package: php53-xml
--> Processing Dependency: php53-common = 5.3.3-22.el5_10 for package: php53-imap
--> Processing Dependency: php53-common = 5.3.3-22.el5_10 for package: php53-mysql
--> Running transaction check
---> Package libedit.x86_64 0:3.0-2.20090923cvs.el5.art set to be updated
---> Package php-gd.x86_64 0:5.4.28-34.el5.art set to be updated
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
---> Package php-imap.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-mbstring.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-pdo.x86_64 0:5.4.28-34.el5.art set to be updated
---> Package php-xml.x86_64 0:5.4.28-34.el5.art set to be updated
--> Running transaction check
---> Package t1lib.x86_64 0:5.1.2-2.el5.art set to be updated
--> Processing Dependency: libXaw.so.7()(64bit) for package: t1lib
--> Finished Dependency Resolution
t1lib-5.1.2-2.el5.art.x86_64 from atomic has depsolving problems
  --> Missing Dependency: libXaw.so.7()(64bit) is needed by package t1lib-5.1.2-2.el5.art.x86_64 (atomic)
Error: Missing Dependency: libXaw.so.7()(64bit) is needed by package t1lib-5.1.2-2.el5.art.x86_64 (atomic)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Aktualisieren

Es wurde versucht, libxml repo x86_64 zu installieren, es besteht jedoch ein Konflikt mit einem i386 ?!

rpm -Uhv ftp://xmlsoft.org/libxml2/libxml2-2.7.2-1.x86_64.rpm

Retrieving ftp://xmlsoft.org/libxml2/libxml2-2.7.2-1.x86_64.rpm
warning:/var/tmp/rpm-xfer.pqHChZ: Header V4 DSA signature: NOKEY, key ID de95bc1f
Preparing...                ########################################### [100%]
        file/usr/share/man/man1/xmlcatalog.1.gz from install of libxml2-2.7.2-1.x86_64 conflicts with file from package libxml2-2.6.26-2.1.21.el5_9.3.i386
        file/usr/share/man/man1/xmllint.1.gz from install of libxml2-2.7.2-1.x86_64 conflicts with file from package libxml2-2.6.26-2.1.21.el5_9.3.i386

Update 2

Nachdem ich den Tag damit verbracht hatte, meine Haare herauszuziehen, baute ich die VPS und die Viola wieder auf. Alles, was ich erreichen wollte, hat funktioniert. Ich vermute, dass beim ursprünglichen Build ein Fehler aufgetreten ist.

antworten

in der Fehlermeldung

Error: Missing Dependency: libXaw.so.7()(64bit) is needed by package t1lib-5.1.2-2.el5.art.x86_64 (atomic`

Ich denke, Sie sollten prüfen, ob Sie das Paket libXaw installiert haben. oder Sie können yum install libXaw. Ich hoffe, es kann Ihnen helfen,

Sie können versuchen, --skip-broken zu verwenden, um das Problem zu umgehen.

Sie könnten versuchen zu laufen:

package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest

Die Programmpaketbereinigung befindet sich im Paket yum-utils.