fragen stichworte

LDAP und DAV mit AuthnProviderAlias ​​funktionieren nicht

Ich habe eine funktionierende Apache 2.4-Konfiguration für ldap mit svn

<IfModule mod_ssl.c>
<VirtualHost _default_:443>
    ...
    <Location/ldapsvn>
            DAV svn
            SVNParentPath/var/ldapsvn
            SVNAdvertiseV2Protocol Off

            SVNListParentPath Off
            SVNAutoversioning On
            SVNReposName "repo name"

            AuthType Basic
            AuthName "My auth"

            AuthBasicProvider ldap
            AuthLDAPURL "ldap://ldapserver:port/DC=abc-de,DC=si?userPrincipalName?sub?(objectClass=*)"
            AuthLDAPBindDN "CN=ldapp,OU=System;OU=Users;OU=XYZ;DC=xyz1;DC=abc-de;DC=si"
            AuthLDAPBindPassword "[[hunter2]]"

            Require valid-user
    </location>

Wenn ich jedoch die ldap-Einstellungen als Alias ​​bezeichne, funktioniert die Authentifizierung nicht mehr

<AuthnProviderAlias ldap ldapAlias1>
   AuthLDAPURL "ldap://ldapserver:port/DC=abc-de,DC=si?userPrincipalName?sub?(objectClass=*)"
   AuthLDAPBindDN "CN=ldapp,OU=System;OU=Users;OU=XYZ;DC=xyz1;DC=abc-de;DC=si"
   AuthLDAPBindPassword "[[hunter2]]"
</AuthnProviderAlias>

<IfModule mod_ssl.c>
<VirtualHost _default_:443>
    ...
    <Location/ldapsvn>
            DAV svn
            SVNParentPath/var/ldapsvn
            SVNAdvertiseV2Protocol Off

            SVNListParentPath Off
            SVNAutoversioning On
            SVNReposName "repo name"

            AuthType Basic
            AuthName "My auth"

            AuthBasicProvider ldapAlias1

            Require valid-user
    </location>

Ich muss irgendwann einen zweiten LDAP-Server hinzufügen, aber ich habe mit einem einzigen versucht, die Konfiguration zu testen.

Jede Hilfe wäre dankbar.

antworten

Ich denke, das wurde als Fehler gemeldet. Fügen Sie Ihre Informationen hier hinzu: https://issues.apache.org/bugzilla/show_bug.cgi?id=55622