fragen stichworte

ssh-Tunnelfehler "ssh_exchange_identification: Verbindung von Remote-Host geschlossen"

Ich versuche, einen SSH-Tunnel von meinem Büromaschine zu meinem Heimcomputer zu verwenden, und erhalte eine Fehlermeldung, wenn ich versuche, ihn zu benutzen.

Was ich mache, ist eine Shell wie folgt:

ssh -gL 12345:my.home.domain:22 my.home.domain

Dies gibt mir eine richtige Hülle, kein Problem. Normalerweise mache ich dann ssh auf meinem Heimcomputer über diesen Büromaschine:

ssh -p 12345 127.0.0.1

Das hat immer für mich funktioniert, bis ich letzte Woche ein neues System auf meinem Heimcomputer eingerichtet habe (Wechsel von Ubuntu zu Debian). Jetzt bekomme ich einen Fehler. Ich kann immer noch meine anfängliche SSH-Verbindung öffnen, aber wenn ich versuche, diesen Tunnel zu verwenden, erhalte ich (auf dem Büromaschinen) diesen Fehler:

ssh_exchange_identification: Connection closed by remote host

Wenn dies passiert, wird bei der offenen Hülle, durch die ich das Tunneln eingerichtet habe, diese Leitung ausgespuckt:

channel 3: open failed: connect failed: Connection timed out

An welchem ​​Punkt bin ich ratlos. Wenn weitere Informationen benötigt werden, poste ich sie gerne.

==================================

Nachdem ich weiter herumgespielt hatte, habe ich festgestellt, dass ich eine andere Antwort vom Server bekomme (mein Heimcomputer), wenn ich versuche, die verschiedenen Ports zu telnet. Wenn ich es versuche:

telnet my.home.domain 22

Ich bekomme das zurück:

Trying <my ip address>...
Connected to <my domain>.
Escape character is '^]'.
SSH-2.0-OpenSSH_5.5p1 Debian-6+squeeze2

Was würde ich erwarten? Nachdem ich jedoch den Tunnel eingerichtet und dann darauf eingestellt habe, sehe ich diese Antwort:

Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

============== und noch weiter ==================

Gemäß dem Vorschlag von kbulgrien ist hier die Ausgabe vom Clientcomputer mit der Option -v:

ssh -vp 24600 127.0.0.1
OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data/etc/ssh/ssh_config
debug1:/etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 127.0.0.1 [127.0.0.1] port 24600.
debug1: Connection established.
debug1: identity file/home/jacob/.ssh/id_rsa type -1
debug1: identity file/home/jacob/.ssh/id_rsa-cert type -1
debug1: identity file/home/jacob/.ssh/id_dsa type -1
debug1: identity file/home/jacob/.ssh/id_dsa-cert type -1
debug1: identity file/home/jacob/.ssh/id_ecdsa type -1
debug1: identity file/home/jacob/.ssh/id_ecdsa-cert type -1
ssh_exchange_identification: Connection closed by remote host

antworten

Vielleicht, wenn Sie mehr haben als SSH 10 Sitzungen warten auf das Passwort einfügen, haben Sie diese Art von Fehler, ich erinnere mich, dass der letzte ssh-Fehler war, wenn Sie dies überprüfen würden, verwenden Sie den folgenden Befehl

for i in {1..15};do ssh -fNt pippo@remote.server.com & >/dev/null ;done

Ich hatte das gleiche Problem und am Ende habe ich das Problem gelöst, indem /etc/network/interfaces korrigiert wurde:

auto eth0
iface eth0 inet static

oder

auto eth0
iface eth0 inet dhcp

Ohne diese Konfiguration bekomme ich niemals eine umgekehrte Verbindung zu meinem SSH-Tunnel.

Bei einer kürzlich erfolgten Installation ist so etwas passiert. In dieser Situation existierte/etc/hosts.deny und hatte keine Einstellungen, die den Zugriff explizit verweigerten. Daher scheinen die Umstände ähnlich zu sein. Es war notwendig,/etc/hosts.allow zu ändern, um Folgendes hinzuzufügen:

sshd: 192.168.127.0/255.255.255.128

Die IP-Details müssen an Ihre Bedürfnisse angepasst werden oder durch ALL ersetzt werden, wenn keine Bedenken bestehen, SSH von überall aus zuzulassen.

Stoppen Sie nach dem Durchführen der Änderungen sshd und starten Sie es erneut.

Die Antworten auf die folgende Frage haben mehr Beispiele.

SSH hosts.deny und hosts.allow

Hier ist ein Zeugnis eines anderen, der die Fehlermeldung mit der Lösung verknüpft.

Vorgehensweise: ssh_exchange_identification: Verbindung wurde durch Remotehostproblem beim Anmelden mit SSH

geschlossen