fragen stichworte

So aktivieren Sie HTTP-Loopback-Verbindungen

Ich lasse CentOS Version 5.8 (Final) für meinen WordPress-Blog (www.deluxeblogtips.com) laufen. Ich habe ein Backup-Plugin BackupBuddy und es heißt:

HTTP Loopback Connections are not enabled on this server

Nach einigen Versuchen bei Google habe ich einige Lösungen gefunden, die jedoch nicht funktionieren. Die beste Antwort, die ich denke, ist das Ändern der /etc/hosts -Datei, und ich habe das bereits getan:

127.0.0.1 localhost localhost6 localhost.localdomain localhost6.localdomain6
127.0.0.1 taiphanmem.org www.taiphanmem.org
127.0.0.1 deluxeblogtips.com www.deluxeblogtips.com
::1       localhost localhost6 localhost.localdomain localhost6.localdomain6
::1       deluxeblogtips.com www.deluxeblogtips.com
::1       taiphanmem.org www.taiphanmem.org

Die Warnung des Plugins wird jedoch weiterhin angezeigt.

Ich habe auch in der Befehlszeile getestet:

wget www.deluxeblogtips.com
curl www.deluxeblogtips.com
telnet 0 80

Alle arbeiten.

Ich weiß nicht, was jetzt gerade ist. Mein Blog läuft langsam und ich denke, die HTTP-Loopback-Verbindung ist das Hauptproblem. Jede Hilfe wird geschätzt! Vielen Dank!

Bearbeiten:

Weitere Informationen zum Webserver (Apache)

Listen 80

Und

apachectl -S
VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
*:80                   is a NameVirtualHost
         default server taiphanmem.org (/usr/local/apache/conf/extra/httpd-vhosts.conf:2)
         port 80 namevhost taiphanmem.org (/usr/local/apache/conf/extra/httpd-vhosts.conf:2)
         port 80 namevhost deluxeblogtips.com (/usr/local/apache/conf/extra/httpd-vhosts.conf:9)
Syntax OK

(Ich hoste auch einige andere Sites auf dem Server, der Standardwert ist taiphanmem.org)

antworten

Die Lösung besteht darin, den Server anzuweisen, mit dem richtigen Inhalt für die auf 127.0.0.1 gerichteten Anfragen zu antworten. Dazu benötigen Sie eine VirtualHost-Anweisung, die mit dieser Loopback-Adresse verknüpft ist:

<VirtualHost 127.0.0.1>
DocumentRoot/var/www/yourdomain
ServerName www.yourdomain.ro
ServerAlias yourdomain.ro
ServerAdmin user@domain.com                                                                           
ErrorLog  logs/webserv/xgraphic_error_log
CustomLog logs/access_log combined
</VirtualHost>

Sie benötigen einen Eintrag dieses Typs für jede Domäne, die Sie auf dem Server hosten, obwohl Sie möglicherweise bereits einen Eintrag für Ihre Domäne haben.

Cosmin Ioachim Damian.

Nach den Zeilen von Cosmins Antwort, aber nicht ganz, hatte ich dieses Problem, weil mein vhost-Eintrag nicht vollständig konfiguriert war. Viele Leute folgen einfachen lokalen Dev Vhost-Tutorials, die Ihnen nur die Grundlagen zeigen. Tatsächlich benötigen Sie einen vollständigeren vhost-Eintrag, einschließlich Regeln, der dies ohne Host-Dateien voodoo (jenseits von 127.0.0.1 example.com)

löst

Datei:/etc/hosts

# Localhost
127.0.0.1  localhost
::1        localhost

# Your custom, local dev site
127.0.0.1  local.example.com
::1        local.example.com

Datei:/path/to/apache2/extras/httpd-vhosts.conf:

<VirtualHost *:80>
ServerName local.example.com
ServerAlias local.example.com
DocumentRoot "/Users/examplename/Sites/example.com"
<Directory "/Users/examplename/Sites/example.com">
    Options Indexes FollowSymLinks Includes execCGI
    AllowOverride None
    Order Allow,Deny
    Allow From All
</Directory>

Jetzt gibt es mehr als Sie benötigen. Aber es funktioniert.

Zumindest für mich.