fragen stichworte

Pure-FTPD-Chroot funktioniert nicht bei einer neuen Debian-Installation?

Ich versuche, chroot mit virtuellen Pure-FTPD-Benutzern zu arbeiten, aber aus irgendeinem Grund funktioniert es einfach nicht.

Ich habe die folgenden Optionen geändert:

/etc/default/pure-ftpd-common:

VIRTUALCHROOT=true

/etc/pure-ftpd/conf/ChrootEveryone:

yes

Und einen virtuellen Benutzer mit einem Homedirectory hinzugefügt, der wie folgt aussieht:

Login              : <someuser>
Password           : <foo>
UID                : 1003 (ftpuser)
GID                : 1003 (ftpgroup)
Directory          :/home/<homedir>/./

Was fehlt mir hier?

antworten

Versuchen Sie, VIRTUALCHROOT = false und "/./" im Benutzerverzeichnis zu setzen.

/etc/default/pure-ftpd-common:

VIRTUALCHROOT=false

cat/etc/pure-ftpd/conf/ChrootEveryone:

yes

Beim Neustart gibt es eine Option:

/etc/init.d/pure-ftpd restart Restarting ftp server: Running:/usr/sbin/pure-ftpd -l pam -O clf:/var/log/pure->ftpd/transfer.log -u 1000 -E -A -8 UTF-8 -B

/etc/passwd:

test:x:1001:1001::/home/test:/bin/sh

Chroot work:

# ftp localhost
Connected to localhost.
220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 1 of 50 allowed.
220-Local time is now 11:03. Server port: 21.
220-This is a private system - No anonymous login
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 15 minutes of inactivity.
Name (localhost:ooshro): test
331 User test OK. Password required
Password:
230-User test has group access to:  test      
230 OK. Current restricted directory is/
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> ls
200 PORT command successful
150 Connecting to port 40034
226-Options: -l 
226 0 matches total

Das Problem wurde gelöst.

Es stellte sich heraus, dass mein FTP-Server anstelle von Standalone durch inetd lief.

Bei der Konfiguration im inetd-Modus wird das Konf-Verzeichnis scheinbar ignoriert.