fragen stichworte

Redmine auf Ubuntu installieren 10.10

Ich habe meine Versuche, Redmine auf einer CentOS-Maschine zu installieren, aufgegeben und stattdessen Ubuntu 10.10 darauf gelöscht, da dies bei vielen Versuchen, die ich online gesehen habe, zu funktionieren schien.

Nicht für mich ...

Ich bekomme etwas, das wie ein Kompilierungsfehler aussieht, wenn ich zur Maschine (http zu seiner IP-Adresse) gehe (was wahrscheinlich bedeutet, dass Apache2 so funktioniert, wie es sollte?). In der angehängten Fehlermeldung finden Sie weitere Informationen.

Weiß jemand, wo man mit diesem anfangen soll?

These are the possible causes:

    *
      There may be a syntax error in the application's code. Please check for such errors and fix them.
    *
      A required library may not installed. Please install all libraries that this application requires.
    *
      The application may not be properly configured. Please check whether all configuration files are written correctly, fix any incorrect configurations, and restart this application.
    *
      A service that the application relies on (such as the database server or the Ferret search engine server) may not have been started. Please start that service.

Further information about the error may have been written to the application's log file. Please check it in order to analyse the problem.

Error message:
    syntax error on line 76, col 0: `production:'
Exception class:
    ArgumentError
Application root:
   /var/www/redmine 
Backtrace:
    #   File    Line    Location
    0  /usr/lib/ruby/1.8/yaml.rb   133     in `load'
    1  /usr/lib/ruby/1.8/yaml.rb   133     in `load'
    2  /usr/lib/ruby/1.8/yaml.rb   144     in `load_file'
    3  /usr/lib/ruby/1.8/yaml.rb   143     in `open'
    4  /usr/lib/ruby/1.8/yaml.rb   143     in `load_file'
    5  /var/www/redmine/config/initializers/40-email.rb    6   
    6  /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb   147     in `load_without_new_constant_marking'
    7  /var/lib/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb   147     in `load'
    8  /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb   622     in `load_application_initializers'
    9  /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb   621     in `each'
    10 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb   621     in `load_application_initializers'
    11 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb   176     in `process'
    12 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb   113     in `send'
    13 /var/lib/gems/1.8/gems/rails-2.3.5/lib/initializer.rb   113     in `run'
    14 /var/www/redmine/config/environment.rb  20  
    15 /usr/lib/ruby/1.8/rubygems/custom_require.rb    31  in `gem_original_require'
    16 /usr/lib/ruby/1.8/rubygems/custom_require.rb    31  in `require'
    17 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/classic_rails/application_spawner.rb   222     in `preload_application'
    18 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/classic_rails/application_spawner.rb   181     in `initialize_server'
    19 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/utils.rb   564     in `report_app_init_status'
    20 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/classic_rails/application_spawner.rb   174     in `initialize_server'
    21 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server.rb     204     in `start_synchronously'
    22 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server.rb     180     in `start'
    23 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/classic_rails/application_spawner.rb   149     in `start'
    24 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/spawn_manager.rb   219     in `spawn_rails_application'
    25 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server_collection.rb  132     in `lookup_or_add'
    26 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/spawn_manager.rb   214     in `spawn_rails_application'
    27 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server_collection.rb  82  in `synchronize'
    28 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server_collection.rb  79  in `synchronize'
    29 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/spawn_manager.rb   213     in `spawn_rails_application'
    30 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/spawn_manager.rb   132     in `spawn_application'
    31 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/spawn_manager.rb   275     in `handle_spawn_application'
    32 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server.rb     357     in `__send__'
    33 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server.rb     357     in `server_main_loop'
    34 /var/lib/gems/1.8/gems/passenger-3.0.0/lib/phusion_passenger/abstract_server.rb     206     in `start_synchronously'
    35 /var/lib/gems/1.8/gems/passenger-3.0.0/helper-scripts/passenger-spawn-server    99  

Nur um klar zu sein; Ich versuche, Redmine auf Ubuntu 10.10 zu installieren. Apache2 läuft als Webserver und ich habe Ruby 1.8.7 und Rails 2.3.5 installiert, da Redmine diese Version benötigt.

BEARBEITEN: email.yml:

 production:
   delivery_method: :smtp
   smtp_settings:
     tls: true
     address: "smtp.googlemail.com"
     port: 587
     domain: "domain.com"
     authentication: :plain
     user_name: "noreply@domain.com"
     password: xxxxxxx

Ich habe keine Anführungszeichen für das Passwort verwendet. Alles andere in email.yml wird mit #

auskommentiert

antworten

Sie haben irgendwo einen Syntaxfehler in einer YAML-Konfigurationsdatei, deren Zeile 76 mit "production:" beginnt. Es sollte einfach genug für grep sein. Darüber hinaus haben wir nicht genügend Informationen - wenn Sie aus der Datei nicht herausfinden können, was zu tun ist, sollten Sie sie veröffentlichen.