fragen stichworte

Probleme beim Servieren von SVN über HTTPS unter Ubuntu 10.04

Nach dem Upgrade auf Ubuntu 10.04 sind Probleme mit unserem Subversion-Server aufgetreten. Beim Versuch, auf ein Repository zuzugreifen, unabhängig vom Client (ich habe git-svn und svn unter Windows sowie svn unter Ubuntu 10.04 von verschiedenen Computern und Netzwerkstandorten aus versucht), erhalte ich eine 400-fehlerhafte Anfrage. Hier ist die Ausgabe von svn:

svn: Server sent unexpected return value (400 Bad Request) in response to
     OPTIONS request for 'https://svn.example.org/svn/programs'

Hier sind die relevanten Einträge aus den Apache-Protokollen (ich verwende Apache 2.2):

error.log

[Mon Jun 14 11:29:31 2010] [error] [client x.x.x.x] 
                           request failed: error reading the headers

ssl_access.log

x.x.x.x - - [14/Jun/2010:11:29:28 +0200] "OPTIONS/svn/programs HTTP/1.1" 
            401 2643 "-" "SVN/1.6.6 (r40053) neon/0.29.0"
x.x.x.x - - [14/Jun/2010:11:29:31 +0200] "ction-set/></D:options>OPTIONS 
           /svn/programs HTTP/1.1" 400 644 "-" "SVN/1.6.6 (r40053)
            neon/0.29.0"

Wenn jemand auf ähnliche Probleme gestoßen ist oder mir einen Hinweis geben könnte, um die Ursache zu ermitteln, wäre ich sehr dankbar - ich möchte wirklich vermeiden, die Box erneut herunterstufen zu müssen.

Editieren 2010-09-30:

Es wurde ein Update vorgeschlagen, das jetzt in lucid vorgeschlagen wird: apache2 2.2.14-5ubuntu8.3. Einzelheiten finden Sie in der akzeptierten Antwort unter dem Link zum Fehlerbericht.

antworten

Ich habe einen Fehler in Ubuntu bezüglich dieses Problems gepostet:

https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/595116

Vielleicht habe ich eine Lösung gefunden (Fehler in der Routine memcpy) https://bugs.launchpad.net/bugs/609290